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1.  Introduction 
 
 The cataclysmic variable group at The Florida Institute of Technology (FIT) is 
happy to present FITDISK, our cataclysmic variable (CV) accretion disk simulator.  
FITDISK is a 3-D smoothed particle hydrodynamics code which simulates accretion disk 
formation and evolution in CVs.  It provides an easy to use graphical user interface as 
well as 3-D interactive graphics and runs under the WindowsXP operating system.  The 
current version of the code has the following capabilities: computes the evolution of a CV 
accretion disk, visualizes results in real time, records and plays back simulations, and 
generates and plots pseudo light curves and associated amplitude spectra.  This manual 
has two primary purposes: first, to give a brief overview of the capabilities and purpose 
of FITDISK, and second, to provide step by step instructions to ensure proper 
functionality of the program.  An excellent (mostly) non-technical introductory text for 
those wishing to learn more about CVs is “Cataclysmic Variable Stars, How and Why 
They Vary” by Coel Hellier (Hellier 2001). 
 
2.  About FITDISK 
  
 Presented below is a brief description of the FITDISK code, including system 
requirements/usage, purpose, program features, and methods.  For a detailed discussion 
of the background physics and numerics, see Wood, Dolence, & Simpson (2005).  
FITDisk and associated files can be downloaded from http://astro.fit.edu/cv/fitdisk.html. 
 
2.1  System Requirements and Performance Analysis 
 
 FITDISK was designed to minimize hardware requirements as much as possible 
while still being capable of producing meaningful results.  Nonetheless, scientific 
computing is inherently expensive computationally, both in compute time and in resource 
usage (e.g. RAM, hard drive, etc.).  The following information is meant to serve as a 
guide in deciding how to use the program most effectively.  Table 1 gives the basic 
requirements necessary to operate the program, while Table 2 gives some example 
runtimes and file sizes.  The files of interest are recorded simulations as they are by far 
the largest, and sizes reported below correspond to recordings at the highest resolution.  
Note that lowering the resolution, as discussed later in this manual, correspondingly 
lowers the file size. 
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Table 1:  Basic System Requirements 

Operating System Microsoft WindowsXP, Windows 2000 
Processor 466 MHz or faster 
RAM 384 MB or more 
Screen Resolution At least 1024x768 
 

Table 2:  Sample Runtimes and File sizes 
# Particles Smoothing Length Time/orbit File size/orbit 

1000 0.040 12 s 4.06 MB 
1000 0.025 8 s 4.06 MB 
12000 0.020 7:22 m 46.0 MB 
12000 0.010 4:20 m 46.0 MB 
25000 0.010 24:00 m 96.0 MB 

 
2.2  Purpose 
 
 FITDISK was developed by putting a user-friendly graphical user interface (GUI) 
front-end onto our research hydrodynamics code.  Our goal with this project has been to 
make the hydrodynamics simulations of CVs possible for interested amateur astronomers, 
students, and professionals.  Whether in an instructional setting or at home on a personal 
computer, FITDISK can be a fun, easy way to learn about these exotic systems and to 
build a better physical intuition for accretion disk dynamics.  Amateurs and professionals 
alike often observe CVs, yet no simple means exist by which one can visualize and 
experiment with these phenomena.  FITDISK was designed to fill that gap, providing an 
opportunity to gain a greater understanding of how these systems behave under a wide 
range of conditions. 
 In addition, FITDISK has its origins in a research code developed at Florida Tech 
and, apart from the addition of the GUI and OpenGL® based visualization, has been 
modified only slightly from its original form.  Thus, it provides a unique opportunity to 
use research-grade simulation software without advanced programming skills and using 
readily available computer hardware.  
 
2.3  Capabilities 
 
 As previously mentioned, FITDISK simulates CV systems.  Specifically, it models 
a fluid disk as formed by mass transfer from a lower mass secondary star to a white dwarf 
primary.  In such systems, there are many physical interactions that lead to the observed 
behavior, and modeling all of these is enormously complex.  Thus, it is necessary to make 
simplifications, including only those interactions thought to be most important.  At 
present, FITDISK accounts for the gravitational force caused by each of the stars as well 
as the hydrodynamic forces inherent to viscous compressible fluid flow.  Therefore, it 
does not account for radiative transfer effects or magnetic field interactions.  Nonetheless, 
FITDISK shows the characteristic dynamics of accretion phenomena in non-magnetic 
CVs, including superhumps and spiral shocks.  As a connection to observational studies, 
FITDISK also has the ability to generate pseudo light curves for simulated systems.  This 
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has been shown to reproduce the characteristic light curve modulation of superhumps by 
Simpson & Wood (1998). 
 FITDISK has many features in addition to the physics engine described above.  Its 
graphical user interface provides an easy way to set up disks to explore a large volume of 
parameter space (i.e., masses of the stars, number of particles, etc.).  Visualization is done 
with OpenGL® double-buffered graphics which provides for a smoothly-rendered 3-D 
interactive environment.  The view can be rotated about two axes independently which 
allows the user to see the CV at any orientation desired.  As these simulations are often 
very computationally intensive and thus take a significant amount of time to run, it is 
frequently desirable to record the simulation so that it may be viewed at a later time.  
FITDISK provides support for this as well, and allows the user control over exactly how 
the simulation is recorded.  For the same reason, restart files can also be output so that a 
simulation can be extended without the need to recompute the entire evolution from the 
beginning.  In addition, light curve outputs can be plotted within the program, showing 
the raw energy generation data as well as a smoothed approximation, and the amplitude 
spectrum (Fourier transform) of the time series data. 
 
2.4  Numerical Methods 
  

Smoothed particle hydrodynamics (SPH) is a numerical technique for solving the 
equations of fluid mechanics.  It was developed independently by Gingold & Monaghan 
(1977) and Lucy (1977), and a great deal of work has since been done towards its 
advancement (see Monaghan 2005 for a recent review).  The key aspect of the algorithm 
is its treatment of continuous fluids as collections of discrete particles. One way to look at 
the method is to imagine that the particles are point markers in the fluid, similar to the 
“ping pong balls with fins” from the 1996 movie Twister.  Fluid variables, such as 
density, are obtained by interpolating over nearby particles, which essentially means that 
the variables are computed at the locations of each particle and are some weighted 
average of its own and nearby particle properties.  This means that no time is wasted 
modeling empty space, as is often necessary in more traditional Eulerian grid-based 
techniques.  A crucial component of the algorithm is the selection of an appropriate 
smoothing length, h.  For computing fluid properties, all particles within a distance of 2h 
from the particle currently being considered are used for interpolation.  In FITDISK, the 
smoothing length is constant for all particles over an entire simulation, but can be varied 
by the user during simulation setup.  If this parameter is set too high or low, the simulated 
accretion disk fails to behave like a fluid.  For the purposes of FITDISK, the smoothing 
length should decrease as the number of particles increases.  For a more complete 
discussion of SPH, as well as other algorithms, see Monoghan 2005.  Within our 
simulations, “light curves” are generated by computing the summation over all particles 
of the change in internal energy of each particle over each time step.  This should roughly 
correspond to the bolometric luminosity of the disk, excluding the accretion zone where 
mass strikes the surface of the white dwarf. 

To view the results of these simulations, data visualization techniques are used to 
display the sizable numeric data sets.  The white dwarf and main sequence stars are 
rendered approximately to scale, with the latter shown filling its Roche lobe.  The fluid 
disk is rendered as particles, natural to SPH simulations.  Particles are given color based 
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on either relative density or relative temperature on a continuous scale from red to blue 
(low to high).  This provides an adaptable scale that helps reveal structure throughout 
disk evolution, but also means that it is not possible to extract quantitative data.  The 
screenshot shown in Figure 1 is a typical scene produced after superhump disk 
oscillations have developed.  Frames are rendered in succession as they become available 
such that for small or recorded simulations, the evolution of the disk is shown as a 
smooth interactive animation.  Unfortunately, larger simulations compute too slowly to 
permit smooth animation unless recorded for later playback. 

Light curve analysis is performed by computing the discrete Fourier transform of 
the time series data through use of a fast Fourier transform (FFT) algorithm.  For a 
discussion on FFT algorithms, the reader is directed to Numerical Recipes, which 
includes the technique used in FITDISK as well as several others and can be found on the 
Web.  The resulting amplitude spectra can be used to identify any frequencies present in 
the light curve by locating peaks in the curve that are significantly above the mean. 
 

 
Figure 1:  Screenshot of FITDisk paused during playback of a 
recorded simulation, here colored by relative temperature. 

 
3.  Using FITDISK 
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 In this section are the instructions for operating FITDISK, as well as a brief 
explanation of each of the adjustable parameters.  We present the functions in much the 
same way the program divides its functions: disk setup is discussed first, followed by 
recording/playback and light curves, restarting simulations and finally, miscellaneous 
options and controls. 
 
3.1  Disk Setup 
 
 To setup a new disk, open FITDISK and select “File → New Disk”.  This should 
immediately open the Disk Setup window shown below in Figure 2. 
 

 
Figure 2:  Disk Setup window where all simulation 
parameters are set. 

 
In this window, all adjustable simulation parameters are set by the user and various 
quantities are updated and displayed accordingly.  The parameters are listed below in 
Table 3 along with a brief description.  Selecting the Run button after setting only these 
parameters should result in the program beginning the simulation.  However, in many 
cases it will be desirable to record the simulation so that it may be viewed later with 



 6

increased speed, quality, and interactivity.  See the section on recording/playback for 
instructions. 
 

Table 3:  Simulation Parameters 

M1 
This slider bar sets the mass (in units of solar masses = 2x1030 kg) of 
the white dwarf primary star M1.  The value is shown immediately right 
of the bar. 

M2 This box shows the value of the mass of the secondary star M2.  It is  
adjusted by varying the mass ratio parameter “q” as described below. 

q 
This slider bar varies the ratio q=M2/M1 by changing the mass of the 
secondary star.  In other words, changing this parameter effectively 
changes M2. 

P_orb The orbital period of the system is shown in this box in units of hours. 

a This box shows the orbital separation of the primary and secondary 
stars in units of the radius of the Sun (7x108 m) 

# Orbits 

This specifies the number of orbits the user wants the program to 
simulate.  WARNING:  Be prepared to wait if many orbits are desired.  
On a reasonably well-equipped desktop computer, a simulation of 100 
orbits with 20,000 particles takes about 24 hours to complete, or 15 
minutes per orbit (still faster than the actual CVs!). 

# Particles 
Here, the user can set the number of particles in the simulation.  More 
particles means better resolution, but the program can be slowed 
substantially.  The maximum number of particles is 25,000. 

# Steps b/n 
Displ. Update 

This sets how often the program updates the display.  Typically, this 
can be left at one or two without a significant loss in program 
performance. 

# Inj/dt 
Users specify here how many particles should be injected into the 
system per time step until the value specified in “# Particles” is 
reached. 

Smoothing 
Length:  h 

This slider sets the smoothing length used for hydrodynamic 
calculations.  If many particles are used, this should be set relatively 
low, whereas for fewer particles, a larger smoothing length should be 
used. 

Viscosity: 
α, β 

These parameters set the coefficients for artificial viscosity as described 
in Wood, Dolence, & Simpson (2005). Increasing either of these 
parameters increases the disk viscosity. 

 
 

3.2  Recording/Playback and Light Curve Output 
 
 Recording of simulations is also accomplished through the Disk Setup window 
shown above in Figure 2.  All recording options are located in the Recording Control box 
and include the following: 
 
• Start recording simulation at orbit #:  The check box at left indicates whether the   

simulation is or is not to be recorded.  To 
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the right, the user can specify on which 
orbit to begin recording.  This feature is 
useful as the disk formation is often not 
the desirable portion of the simulation.  In 
addition, this serves as a practical way to 
keep file sizes lower. 

 
• Start recording light curve at orbit #:   The check box to the immediate left indicates 

whether light curve output will be generated.  
File sizes, even for many orbits, are of only 
modest size so the user need not worry about 
recording the light curve for the entire run.  
However, the option is to the right for users 
who wish only to record certain orbits, 
perhaps for later analysis through use of a 
DFT. 

 
• Recording Resolution:  This slider controls how often frames are output in the 

recording of a simulation.  At the highest setting, all 
frames (200 per orbit) are used in the recording.  For the 
setting just below this, every other frame is used, and it 
continues in this way (i.e. every third frame for the next 
setting, etc.) until, at the lowest setting, only every sixth 
frame is used.  This can result in a significant savings in 
file size, but degrades the quality of the recording.  Note 
that this setting does not affect the resolution of light 
curve output. 

 
If a check box is filled and the “Run” button is clicked, the “Save As” box should appear.  
This is where the user can enter the name of the recording and select where in the file 
system it should be saved.  Recorded simulations will bear the name you enter appended 
with a “.fit” extension, while light curve files will carry the tag “_lc.fit” appended to the 
name entered. 
 Playback of recorded simulations is exceptionally simple.  Go to “File → Open 
Recorded” and then select the file that is to be displayed.  All FITDISK output files have a 
“.fit” extension, but recorded simulations do not have “_lc” or “_rs” at the end of the 
name.  This should serve to distinguish between different FITDISK file types.  Two useful 
features for playback are looping and pausing.  To have a recorded simulation loop 
during playback, be sure that the “Loop Playback” listing in the Options menu is checked 
(it is checked by default) before it starts.  Pausing playback is accomplished by clicking 
the “PAUSE” button in the lower left corner of the window, while clicking it again will 
resume playback.  To exit the playback of a simulation, the user can simply click the 
“QUIT” button, also in the lower left corner of the window. 
 
3.3  Lightcurve Plotting/Analysis 
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 Light curve plotting and analysis can be accessed within FITDISK by going to 
“File → Open Lightcurve”.  The window shown below in Figure 3 should appear which 
tells the user the current file name and how many orbits of light curve data are within it,  
 

 
Figure 3:  Light Curve Plot Control window, 
where users can select which orbits of a light 
curve to plot and analyze 

 
and asks which of those orbits are to be used.  Once the appropriate values are entered 
and the “OK” button is selected, the light curve and its associated amplitude spectrum are 
plotted as shown in Figure 4.  It is important to note that only those orbits which show an 
oscillation should be used if one is interested in determining any relevant frequencies.  
This typically means that the first 20-50 orbits must be excluded from the analysis for 
peaks such as those in Figure 4 to become apparent. 
 Additionally, the light curve can easily be plotted with other data analysis and/or 
plotting programs as the data is output as a standard space delimited text file.  Note that 
the first line of the data file tells FITDisk how many data points to expect, and thus is not 
part of the data and should be ignored by 3rd party plotting programs. 
 
3.3  Extending a Simulation Using a Restart File 
 
 FITDISK has the ability to output a file from which a simulation can be continued, 
alleviating the need to recompute an entire run for only some number of additional orbits.  
For example, if the user was to run a simulation out to 80 orbits and then realize that 
some interesting phenomena, perhaps superhumps, were only just beginning, it would be 
a simple matter to load the restart file and compute a few more orbits.  Conversely, it 
would be an enormous waste of CPU time to recompute the entire evolution when only 
those orbits at the end of the run have the desirable features.  Also, it is generally a good 
idea to have a restart file output every few orbits so that if the simulation is stopped for 
some reason before completion, only a modest amount of time is lost, instead of the 
entire run. 
 To setup FITDISK to write restart files, the user must enter the appropriate 
information in the “Restart File Write Control” box in the lower portion of the Disk Setup 
window shown in Figure 2.  Checking the box at left makes FITDISK write restart files, 
while the number entered at right controls how often it should write these files.  If this 
box is checked and the Run button is selected, the Save As box should appear for the user 
to enter the desired name and file location.  Note that restart files have the tag “_rs.fit” 
appended to the name entered. 
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 Once FITDISK creates a restart file, it is a simple matter to load the file and 
continue the disk’s evolution.  To open a restart file go to “File → Open Restart”.  This 
should immediately bring up a window where the user can select the file to open.  After 
this selection is made, another window should appear, shown below in Figure 4.  Here, 
the user enters the information in much the same way as for the setup of a new disk.  The 
only exception is that the user specifies how many more orbits are desired, and on which 
of these to start recording.  Of course, the other simulation parameters (i.e., mass, number 
of particles, etc.) cannot change from what was originally modeled. 
 

 
Figure 4:  Light curve plot and associated amplitude spectrum 
for a simulation with 25,000 particles with q = 0.01.  From left 
to right, the peaks in the spectrum represent the fundamental 
superhump frequency, and the second and third harmonics. 
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Figure 4:  The Restart Control window is used to set 
parameters for extending a previously calculated 
simulation. 

 
3.4  Miscellaneous Controls and Options 
 
 Available for any simulation, currently computing or being played back, is the 
ability to rotate the view.  Clicking and dragging the mouse within the window causes the 
view to rotate by an angle displayed in the title bar (at top).  Both the left and right mouse 
buttons rotate the view, each about an independent axis.  This is an essential feature as it 
provides the user with a view of the disk at any desired orientation.  Figure 1 above 
shows a screenshot of a simulation being played back, with angles of rotation labeled “X- 
Angle” and “Y-Angle” in the title bar. 
 Several additional options exist which do not neatly fit into any of the above 
categories.  These are as follows: 
 
• Star style:  The stars can be drawn as filled objects (default), grids of lines, or as 

points at the grid intersections.  Some computers see a speed increase 
from displaying the stars as lines or points rather than solid objects, 
which becomes increasingly true as the size of the secondary 
increases.  To change this setting go to “Options → Star Style” and 
select that which is desired. 

 
• Particle size:  Two sizes exist, small (default) and large.  Typically, this should be 

left on small for personal use.  Users who wish to show FITDISK 
over a projector may find that large particles show up significantly 
better, especially for distant viewers.  This setting is changed by 
going to “Options → Particle Size” and selecting large. 

 
• Particle color:  Before starting a simulation (in either compute or playback mode), 

the user can select to color the disk by relative density or relative 
temperature.  The default is to color by density, but to change this 
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go to “Options → Particle Color” and select temperature.  This 
setting will reset upon restart of the application. 

 
• Show Simulation:  The user can optionally select not to display the simulation as it 

computes.  Some systems may experience a speed increase if 
this option is selected, but typically the visualization comprises 
only a small fraction of compute time. 

 
 
4.  Concluding Remarks 
 
 We hope you will find FITDisk a valuable tool and welcome questions/comments 
about your experience.  Contact information can be found on the web at 
http://astro.fit.edu/cv/fitdisk.html. 
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